Workspace Port Not Found

I keep getting “Workspace Port Not Found” even though the port is open and I can curl to it on the terminal.

This was annoying, as at first, this page would show for around a minute every time the app reloads, but now it’s making the workspace unusable.

There seems to be a cron job or something that checks the open ports every minute and the server seems to return Port Not Found until the cron job finds the port. Is there a way to disable this completely and just allow all ports on default?

This was just annoying when it was unavailable for a minute or two, but now waiting doesn’t seem to help, and only re-starting the workspace works.

Have you tried listing the required ports in the .gitpod.yml?