Vscode vim extension not working

Is anyone having issues with the vscode vim extension?, i’ve noticed that it stopped working all of a sudden. i’ve disabled, re-enabled, uninstalled it and nothing seems to fix. This is the 2nd time that this has happened, so I’m wondering if this might have something to do with an update? Also I’m using gitpod from IpadOS safari if that helps.

Last time, it randomly fixed itself after some time. Any help or ideas would be appreciated - thanks!

UPDATE: I’ve tested this in chrome desktop as well and can verify that it’s not working there either.

1 Like

Thank you for reporting. We are investigating.

It is an issue in upstream: https://github.com/VSCodeVim/Vim/issues/7150

As a workaround you can connect to Gitpod workspace using VS Code Desktop: VS Code Desktop Support
Or downgrade the extension from the extension view. You will need to change settings though to disable auto extensions update and downgrade for each new workspace.

I’ll keep an eye on the issue - thanks for your response @akosyakov !

installing and rolling back to vscodevim v1.21.7 will fix the issue for now until a new update comes out.

1 Like