Vetur extension not working


I just tried to install Vetur ( for our Vue.js project, but got an error saying “Activating extension Vetur failed: Cannot read property ‘includes’ of undefined.” Locally in VSCode this works without problems.
After this message, syntax highlighting works, but everything else (e.g., autocomplation in TS code) doese not.

Are there any known issues with vetur in Gitpod?

Workspace id this is happening in: c9293224-105c-442b-b664-6182d5b35713

Kind regards,

1 Like

Hm I also tried the repositories linked in the official Gitpod documentation, but had no luck.
It’s strange that vetur explicitly is mentioned in the Gitpod docs ( but does not work. In the screenshot it does seem to work though :confused: If there are any additional setup steps to be taken, it would be really helpful if those were documented.

I also found this issue on GitHub regarding Vetur not working, but it seems to be stale:

Can anyone give me hint regarding the status of this issue? Maybe @JesterOrNot / @svenefftinge as you also answered on the issue :slight_smile:

Kind regards,

This has been fixed already in our staging environment. We are working on getting it out ASAP, but cannot yet commit on a day, but will be this month.


Awesome! Thank you so much :slight_smile:

Hi @svenefftinge :slight_smile:
Are there any updates on this issue?
I just tried the nuxt.js example on GitPod’s homepage, but unfortunatly the plugin still throws the same error.
Kind regards,

Hi @Sandared! Like @svenefftinge mentioned above this has been already fixed in our staging environment and will be soon deployed in production at This is planned to happen within the next days, stay tuned!

I’ve also opened a pull request in for updating the version of the extension used in the Nuxt project from 0.22.6 to 0.28.0.

1 Like

Hi @gtsiolis :slight_smile:

can you tell me if this fix is already in production? I just tried vetur again and for me it still doesn’t work. I just want to make sure if it’s me doing something wrong or if this fix has not been deployed yet :slight_smile:

Kind regards,



Hi all, it is not in production yet. We plan to release by the end of this month.

Thanks for the update @svenefftinge :slight_smile:

Hi, is there any plan on when this will be deployed to production? I think it’s not working yet.

Hey @micksp, the specific issue mentioned in the description has been already resolved and the fix has been deployed to production (

Activating extension Vetur failed: Cannot read property ‘includes’ of undefined.

However, I see there’s a new warning now after installing the extension when using Theia editor although syntax highlighting for Vue files works as expected.

Activating extension ‘Vetur’ failed: The language client requires VS Code version ^1.52.0 but received version 1.44.0

This is probably an issue related to Theia editor. Looping in @akosyakov in case opening an issue in eclipse-theia/theia would be best here.

suggestion: In any case, I’d suggest switching to Code editor through the Feature Preview as a) the extension seems to be working as expected with Code and b) we’re planning to default to Code editor and deprecate allow users to bring their own web IDE, including Theia editor, through a docker image, over the next couple of months. :nerd_face:

Well, I don’t know what happened, but this morning suddenly everything works!
Vetur works, I now have syntax highlighting everywhere (yesterday: nowhere). And all icons are now showing (yesterday al squares, like: fonts didn’t load)

I can’t find Feature preview in the settings. But for now: I’m happy :sunglasses: