Unable to load extensions

We are running gitpod 0.5.0 on a bare metal kubernetes cluster. When trying to install an extension we get an error as seen in this image:
screenshot

When digging through the logs we found this error message:

{"component":"workspace","severity":"error","time":"2020-11-05T13:07:11.030Z","message":"Bad
Request: /plugin returned with code
400.","payload":{"name":"root","params":[null]}}
{"component":"workspace","severity":"error","time":"2020-11-05T13:07:11.030Z","message":"Upload
failed: Bad Request","payload":{"name":"root","params":["Error: Bad Request\n
at Request._callback
(/theia/node_modules/@gitpod/gitpod-extension/lib/node/extensions/gitpod-plugin- 
deployer.js:582:44)\n
at Request.self.callback (/theia/node_modules/request/request.js:185:22)\n at
Request.emit (events.js:315:20)\n    at Request.<anonymous>
(/theia/node_modules/request/request.js:1161:10)\n    at Request.emit
(events.js:315:20)\n    at IncomingMessage.<anonymous>
(/theia/node_modules/request/request.js:1083:12)\n    at Object.onceWrapper
(events.js:421:28)\n    at IncomingMessage.emit (events.js:327:22)\n    at
endReadableNT (_stream_readable.js:1220:12)\n    at processTicksAndRejections
(internal/process/task_queues.js:84:21)"]}}
{"component":"workspace","severity":"error","time":"2020-11-05T13:07:11.030Z","message":"Request
upload failed with error: Upload
failed","payload":{"name":"root","params":["Error: Upload failed\n    at
GitpodPluginDeployer.<anonymous>
(/theia/node_modules/@gitpod/gitpod-extension/lib/node/extensions/gitpod-plugin- 
deployer.js:618:31)\n at step
(/theia/node_modules/@gitpod/gitpod-extension/lib/node/extensions/gitpod-plugin- 
deployer.js:47:23)\n at Object.throw
(/theia/node_modules/@gitpod/gitpod-extension/lib/node/extensions/gitpod-plugin- 
deployer.js:28:53)\n at rejected
(/theia/node_modules/@gitpod/gitpod-extension/lib/node/extensions/gitpod-plugin- 
deployer.js:20:65)\n
at runMicrotasks (<anonymous>)\n    at processTicksAndRejections
(internal/process/task_queues.js:97:5)"]}}
{"component":"workspace","severity":"error","time":"2020-11-05T13:07:11.120Z","message":"Failed
to share henriburau.hello-world@0.0.1 extension from
hello-world-0.0.1.vsix","payload":{"name":"root","params":["Error: Request
'upload' failed\n    at Proxy.<anonymous>
(https://c1f2c2a7-630b-471a-809a-b6956536956e.ws.example.org/bundle.js:57:170914)\n
at e.<anonymous>
(https://c1f2c2a7-630b-471a-809a-b6956536956e.ws.example.org/bundle.js:57:112651)\n
at
https://c1f2c2a7-630b-471a-809a-b6956536956e.ws.example.org/bundle.js:57:110311\n
at Object.next
(https://c1f2c2a7-630b-471a-809a-b6956536956e.ws.example.org/bundle.js:57:110416)\n
at a
(https://c1f2c2a7-630b-471a-809a-b6956536956e.ws.example.org/bundle.js:57:109122)"]}}

It seems that there is a entpoint named /plugin which cant be reached. Is that a known issue?

1 Like

It’s this issue: https://github.com/gitpod-io/gitpod/issues/2067

It’s fixed and will be part of the next release.

Thank you very much for your reply! Any insights on when the next release is will be released?

2 Likes

Good question… @corneliusludmann

We are currently working hard on the next release. If all goes well, there will be a new release in December. Because a lot of things changed due to going open source we need to test and bugfix a lot. That takes unusually long. In the future, we will release more frequently.

1 Like

Thank you for your answer. I cross the fingers :slight_smile:

1 Like