The workbench failed to connect to the server (Error: TIMEOUT) - again

While working I ran into connection problems to the server. The GitPod status page says everything is all working well. Are there any problems with GitPod infrastructure right now or has anybody some hint what I could do?

An unexpected error occurred that requires a reload of this page.

The workbench failed to connect to the server (Error: TIMEOUT)

After some time it works again. Happened twice in the last hour or so.

There were some issues yesterday in your cluster. It looks like they’re settled now. Please let us know if the problem persists.

I get the problem again. Had it last night stopped working. This morning it’s still there reproducible, even when I create a new workspace.

https://gitpod.io/#https://github.com/TeamFranka/affinity/tree/dave/feature%2Fregistration-start-wizard

It keeps me from working and I was thinking maybe there is some misconfiguration, but I can’t find what may be wrong.

I also checked the status page, but there everything seems fine.
https://status.gitpod.io/

Please help.

Hey @davemecha, I could reproduce this one or two times but not reliably. :man_shrugging:

Could you try re-opening the same context again?

Thanks for checking. :+1: :pray: - It is very strange. After I completely restarted the browser it was better and I got access to a workspace again. - Maybe there is some timeout just too short configured, that a browser with low resources may experience such problems. - I’ll watch this and give feedback on future occurrences.

Also, clicking Reload on the modal with the error successfully loaded the workspace. :bulb:

Yeah most of the times, this works. But when I reported the problem this morning I clicked the “Reload” button several times. I tested with several workspaces in different branches. No one worked and I got the same error immediately after the reload - on and on again.

I have the problem again. I just was working and without any warning, this error message suddenly pops up and disrupts my work. - The reload just don’t help. - I try to reboot again…

I’m working from a chromebook.