Syntax highlighting not working

Hi,

My workspace is not showing any syntax highlighting on my computer (I have tried both Firefox and Chrome), but it is working on others’ computer. What could be the issue? I was checking the network connection and a lot of calls to openvsx was blocked due to CORS request.

Here’s the URL to the repo: https://github.com/Malrhis/tgc10-gitpod-demo.git

Thanks for reporting. We are currently investigating why the API calls to OpenVSX are blocked by CORS.

@kunxin-chor, could you try to clear the browser cache (not cookies, this is unrelated).

It seems that this was a caching issue with OpenVSX. The OpenVSX guys fixed this.

1 Like

Hi, it’s still not working. The strange thing is that if I access the running work space of another account, the syntax highlighting works, but it wouldn’t work for workspaces on my own account. I have tried clearing cache and etc.

Hi I have the exact problem kunxin is talking about. not sure if it’s machine specific? cause I tried edge, chrome and firefox and it’s all not working

  1. The Opened editor pans don’t have syntax highlighting
  2. File types are not being detected at the top of the tab. Icons for .py and .html etc are not showing. (not sure if this is related to the syntax highlighting issue

I have the same problem of code not highlighting, strange thing is was working on the workspace on another computer, but now that computer won’t even start the workspace anymore??

Could you please provide the workspace ID (the UUID in the URL of the running workspace or in the workspaces list at gitpod.io/workspaces) when this happens? Or even better: Go to WorkspacesShare Workspace Snapshot and share this link here.

@corneliusludmann https://gitpod.io/#snapshot/56fee9fa-6202-424e-88a5-74df7bbe2c48 Here’s a snapshot. I tried again today and it seems there IS syntax highlighting now.

Not sure if a fix was applied already? I refreshed a few times and the issue was not reproducible.

if a fix was applied recently do let me know what was the root cause, so that we can at least know not to mess up if it’s a client side problem.

Link below for snapshot

Open in Gitpod

Also I checked the console log and there are CORS errors todo with GitPod and VSX???

Has anyone found a solution to this problem? I’ve just recently joined Gitpod and immediately ran into this problem. I know it’s a minor issue however it would make following my course material that much easier. It also seems that when I shared my screen with my course help that they could see that the syntax was highlighted. So it only seems to be an issue from my end. Thanks.

I’m also having this same issue on my workspace! However, icons for the files do seem to be working. Thanks.

Hi @a ! Maybe try going to the Extensions panel (left vertical menu in the IDE) and search for the programming language you want to use? Installing the correct extension can fix syntax highlighting in some cases.