So basically, i'm new to gitpod and, the commands don't show any color different from the texts, how can i fix?

Hi and welcome to the community. Do you have a repository URL you could share so that I can take a look at what’s happening?

I will suppose this is what you’re talking about.

Exactly, thanks for the link.

The colors seem to work in my case:

What is the language mode at the bottom right in the status bar? Make sure this is set to “HTML”:
image

If yours shows something else, you can click on that area of the status bar and search for HTML.

Yeah, it’s set to HTML.

:thinking: A few more questions to troubleshoot:

  1. Do you have Feature Preview enabled at https://gitpod.io/settings? If so, what is your default IDE? If it’s turned off, that’s ok and helps me narrow down the issue too.
  2. Which browser do you use?
  3. What is your operating system?
  4. Do you see colors when you create a new test.js file and add console.log("Hello");?

Thanks

  1. Theia
  2. Firefox
  3. Win10
  4. No

Thanks for the info. It looks like there are related topics:

For some people, it resolved itself. Let me dig a bit deeper and get back to you when I have more details to what may cause the issue you see.

So.

On Firefox and Edge it wasn’t working, but on Brave it does work.