Problems with Docker-Desktop Kubernetes on Win 10 / WSL2

I got interested in trying out Gitpod on my Windows machine so I followed the steps for self installation here. When I first did the helm install I got a bunch of these:

rbac.authorization.k8s.io/v1beta1 ClusterRole is deprecated in v1.17+, unavailable in v1.22+;
rbac.authorization.k8s.io/v1beta1 ClusterRoleBinding is deprecated in v1.17+, unavailable in v1.22+;
rbac.authorization.k8s.io/v1beta1 Role is deprecated in v1.17+, unavailable in v1.22+;
rbac.authorization.k8s.io/v1beta1 RoleBinding is deprecated in v1.17+, unavailable in v1.22+;

I guess just warnings, because otherwise it seems to go through the install just fine.

But then some of the pods wouldn’t go up… I looked through most of the pods and it seems most of them had errors similar to the one you have on your troubleshoot page:

  Warning  FailedMount  113s (x21 over 28m)  kubelet            MountVolume.SetUp failed for volume "node-fs1" : hostPath type check failed: /run/containerd/io.containerd.runtime.v1.linux/k8s.io is not a directory

However I can’t find this directory (or it’s alternatives) anywhere on my WSL distro. I’m using Docker-Desktop Kubernetes version under the WSL2 engine. As I understand it, it basically runs under a different VM as the distro I’m using.

This hostPath should match the directory of the Kubernetes host right? I tried looking around docker-desktop WSL instance but I couldn’t find any of the directories there either.

Now, Docker Desktop does seem to make some of the docker data available in my WSL instance. But I’m unsure which folder it needs or whether it’s taking the directory from my WSL instance (where I run helm install) or is it a folder on the Docker/Kubernetes WSL instance.

This is what mount | grep rootfs says:

overlay on /mnt/wsl/docker-desktop-data/tarcache/entries/docker.tar/d0a522d4fc00053bed5040ca85ca87afdee12a10d2d4345181823479526639c7/containers/services/docker/rootfs type overlay (rw,relatime,lowerdir=/containers/services/docker/lower,upperdir=/containers/services/docker/tmp/upper,workdir=/containers/services/docker/tmp/work)

Some other relevant info. My helm version is 3.5.1, my docker version is 20.10, my kubectl client and server are 1.19. My WSL distro is ArchLinux.

Might just be easier if I just install microk8s in my WSL instance but I do have to get around enabling systemd under my WSL instance (which doesn’t sound that bad since it would be nice to have for other things) but I think this scenario should be possible.

Hi @MinusFour, welcome to the Gitpod community! :tada:

There’s no support for running Gitpod on Widnows. However, you can try running Gitpod in a Docker container instead, see relevant docs. :open_book:

Once you want to proceed, a better solution would be to try one of the self hosted options, see relevant docs. :package: