Language Support for Java Server crashed

Hi Team,

I have gitpod self-hosted installed in GKE cluster. I am trying to run Java Spring Boot application in gitpod but while loading it is showing below error:

Some users are able to start and run the workspace with all Java activation from any repository but few users are facing this issue whenever they tries to start any of Java Spring Boot application from any repository.

1 Like

Hi Team,

Please help me with the issue. Still the issue keeps crashing or keeps in loading phase.

Hi @sumitrathi95!

I’m so sorry for the late response, as this issue is a bit tricky to troubleshoot. But let’s try anyway :raised_hands:

I have a slight suspicion, but it may be a long shot: Have your users tried using Lombok at some point in your self-hosted installation by any chance? I know that it leaves behind some changes in your User Settings that can cause these Java LS crashes.

The fix for this is to:

  1. open File > Settings > Open Preferences
  2. make sure that you are in the User tab
  3. click on the {} icon in the top right
  4. if you see any line that seems to configure Java, try removing it, then save and start a new workspace

For example, I’ve recently needed to remove this line from my User Settings in order to fix the same symptom you’re observing (although on gitpod.io and not self-hosted per se):

  "java.jdt.ls.vmargs": "-noverify -Xmx1G -XX:+UseG1GC -XX:+UseStringDeduplication -javaagent:\"/tmp/vscode-extensions/GabrielBB.vscode-lombok@0.9.9/extension//server/lombok.jar\"",

If that’s the problem, you can also find the offending Settings line in your DB, and e.g. make a query to remove this line for every affected user.

If that’s not the problem, we should look more deeply into logs.

Hi @jan,
Thank you so much your response. This solved the issue. I removed the setting from user and it reflected for the user in every repository access.

1 Like