Installing MongoDB and Heroku doesn't work

These two softwares: mongodb and heroku cli are vital for me.
I have this docker file:

FROM gitpod/workspace-full

USER gitpod

RUN curl https://cli-assets.heroku.com/install.sh | sh

# Install MongoDB
# Source: https://docs.mongodb.com/manual/tutorial/install-mongodb-on-ubuntu-tarball/#install-mongodb-community-edition
RUN mkdir -p /tmp/mongodb && \
    cd /tmp/mongodb && \
    wget -qOmongodb.tgz https://fastdl.mongodb.org/linux/mongodb-linux-x86_64-ubuntu2004-4.4.2.tgz && \
    tar xf mongodb.tgz && \
    cd mongodb-* && \
    sudo cp bin/* /usr/local/bin/ && \
    rm -rf /tmp/mongodb && \
    sudo mkdir -p /data/db && \
    sudo chown gitpod:gitpod -R /data/db

But it doesn’t work. I can’t execute either heroku or mongodb
I tried
ls /usr/bin/local
it returns a directory: dive.
Can anyone help?

Fixed by creating another workspace: this isn’t clear in the docs.

Hi @dragonDScript, welcome to the Gitpod community! :tada:

Also, many thanks for sharing what worked for you in the end. :pray:

Indeed, any Dockerfile or .gitpod.yml changes only take effect when you create new workspaces (i.e. existing old workspaces will not pick up the new/modified configuration).

Could you please share which page of the docs you mostly followed? I’d love to add a note there about creating new workspaces.

Hello Jan, thanks for responding so quickly!
I just created a new workspace to see what happened. Any docs showed this.

Thanks @dragonDScript! Would you have a few URLs of some Gitpod docs pages that you followed? :pray:

Running Docker within Gitpod this!