Ingress for Gitpod

Hello, I have a quick question.

Do I need to have an ingress controller configured?
Because my self-hosted is not accessible through 80 or 443 but on 30100 (or something like that).
and when I try to open a workspace it opens this page: https:///sorry/#Error%20.

Hi @supersebe,

an ingress control cannot be used yet as proxy and ws-proxy are used to forward the requests to the correct pods.

My little work around, since I’m running it on k3d with about 15 other ingresses is using a TCP ingress configuration. Here’s my config for Traefik, should be similar for ingess-nginx:

apiVersion: traefik.containo.us/v1alpha1
kind: IngressRouteTCP
metadata:
  name: gitpod-https
  namespace: gitpod
spec:
  entryPoints:
  - websecure
  routes:
  - kind: Rule
    match: HostSNI(`gitpod.dragns.net`)
    services:
    - name: proxy
      port: 443
  - kind: Rule
    match: HostSNI(`registry.gitpod.dragns.net`)
    services:
    - name: proxy
      port: 443
      terminationDelay: -1
  - kind: Rule
    match: HostSNI(`ws.gitpod.dragns.net`)
    services:
    - name: proxy
      port: 443
  tls:
    passthrough: true

I hope that helps. Please let me know if it helps anyone else out!