Gitpod Installation Fails with Template Error

Hi all,

I’m finally getting back around to setting up Gitpod. I’ve got everything setup, however when I run the helm command to get it installed on my Kubernetes cluster I get the following error:

Error: template: gitpod-selfhosted/charts/gitpod/charts/minio/templates/deployment.yaml:192:20: executing "gitpod-selfhosted/charts/gitpod/charts/minio/templates/deployment.yaml" at <(not .Values.gcsgateway.enabled) (not .Values.azuregateway.enabled) (not .Values.s3gateway.enabled) (not .Values.b2gateway.enabled)>: can't give argument to non-function not .Values.gcsgateway.enabled

I plan on just using the integrated MinIO option so I don’t believe I need to configure anything there.

What can I check on as something that might be causing this?

Thanks!

Oh shoot, I just noticed:

Looking into those now to see if I can figure it out myself.

Update: Confirmed that using steps in this post resolved the issue.

Of note, for some reason it didn’t like me performing the edits on my macOS workstation, but it worked fine using my Gentoo Linux workstation. I think in macOS it was tar’ing up some Mac specific file, ‘_.gitpod’.

2 Likes