.gitpod.Dockerfile/.gitpod.yml not Working

I am trying to have Heroku CLI preinstalled when I start GitPod. I am making a website with Node.JS.

.gitpod.yml file:

image:
  file: .gitpod.Dockerfile

# List the ports you want to expose and what to do when they are served. See https://www.gitpod.io/docs/config-ports/
ports:
  - port: 8080
    onOpen: open-preview

# List the start up tasks. You can start them in parallel in multiple terminals. See https://www.gitpod.io/docs/config-start-tasks/
tasks:
  - init: echo 'init script' # runs during prebuild
    command: echo 'start script'

.gitpod.Dockerfile:

FROM gitpod/workspace-full
USER gitpod

RUN curl https://cli-assets.heroku.com/install-ubuntu.sh | sudo sh

my GitHub Repo:

https://github.com/dragonBall561/unblocked-games

It worked for me.

Check your branch and try again!

snapshot: https://gitpod.io#snapshot/4bf2fa79-35a1-4570-8e31-91f2ba1bc649

2 Likes

I have an error in my .gitpod.yml now…
I am on branch main

Unable to load schema from 'https://gitpod.io/schemas/gitpod-schema.json': No content.

Oh. The snapshot you had worked. I deleted the old one. Thanks!

1 Like