"GitHub API Error. Status: 403"

I tried to use Gitpod again, but am hitting a variation of The remote repository "..." is not accessible with the current token. Please grant the necessary permissions again so am in danger of losing my changes :frowning:

To try to debug or fix this, I tried to open a new Gitpod workspace for prisma/prisma, but now I get the following error when loading Dashboard — Gitpod

No Gitpod for me it seems :frowning:
https://gitpod.io/#https://github.com/prisma/prisma/pull/7581

And a different version now while actually using Gitpod:

Happens right after it tells me I can not push to a repo (correctly this time)

Hi, sorry it hit you again!

The issue seems to be caused by the VS Code pull request extension big pull request not loading · Issue #2741 · microsoft/vscode-pull-request-github · GitHub
Downgrading to 0.25.1 should help:

  1. Wait until you can connect again (took a few minutes for me)
  2. In Gitpod, got to extensions, locate the GitHub Pull Requests Extension and click on the gear icon.
  3. Select Install Another Version, chose 0.25.1 and then click on Reload Required

Thanks for that, will try that maybe later.

Right now this causes me to be unable to login in e.g. to Supabase.io via Auth0 as I also get invalid_request (API rate limit exceeded for user ID 183673.) - and I have not been using GitPod at all today yet.

5000 requests per hour… Resources in the REST API - GitHub Docs (Still rate limited somehow, now also affecting other things like custom GH Actions runner installation)

Very sorry for that but there is little we can do against such misconfigured extensions. Please try the downgrade above.

Is there a way to do this globally for all my Gitpods? I definitely did this already, but seems other workspaces again have 0.26.0 installed. I am getting afraid of using GitPod a bit :frowning:

@janpio the API rate limit is reset after 60 minutes. If you are experiencing this issue after a such a break, this cannot be caused by any extension if that’s not active.

Could it be that you are using some other service which requires to store a personal access token and is eating up the API rate? AFAIK There is a rate limit per token and per GH user.