FROM ubuntu dependencies: ERROR: bash: gp: command not found

I’m setting up a custom Ubuntu workspace. If I test my Dockerfile from my machine I can check the dependencies versions, but I can’t from GitPod. When my workspace loads I get an error: “bash: gp: command not found” and I suspect this might be part of my issue and suspect I’m missing some custom GitPod dependencies. Below is a copy of the Bash shell from my workspace. TIA


bash: gp: command not found
bash: dircolors: command not found
gitpod@ws-3ae24295-1198-431c-812b-9076b9aa0a2a:/workspace/CodeDog$ gcc -version
bash: gcc: command not found

Hi @Tiffany!

Indeed, gp is a custom CLI helper that is (or should be) automatically installed by Gitpod on top of any workspace image (whether you’re using the default image or providing a custom image).

I believe that Gitpod does not require it to be in the PATH, except if your project is using gp, for example if you call things like gp url or gp await-port 8080 in your .gitpod.yml tasks.

Could you please share more information on your setup? E.g. any repository URLs, screenshots, configuration files, etc?

This could help shed more light onto:

  • What is expecting gp to exist?
  • Why gp is not in the PATH?
1 Like

Hi @jan,
Thank you for your response. It took me some time to locate the problem, which was actually with my https://gitpod.io/settings/ Environment Variables. Before I had found the documentation on adding environment variables I found this setting and tried adding one there. It looks like added it in such a way as to overwrite my path. When I removed that environment variable the commands are found. Thanks again.

2 Likes

Hi @Tiffany! Wow, I’m glad you found the root cause of this problem.

Thank you for sharing your solution! I would’ve never thought of checking the environment variables.

1 Like