Extensions not being activated

I am using this repository in Gitpod but for some reason, the extensions are not activated at all. Neither are some of the left sidebar features (like the port explorer)

The extensions tab is completely empty too:

image

This worked fine until a couple of weeks ago, but then I put the project on hold and when I came back, I started encountering this problem. I don’t am not really sure what has actually caused this issue.

1 Like

Hi @IgnisDa, welcome to the Gitpod community!

Also, many thanks for reporting this problem. I’m able to reproduce it when opening your repository in Gitpod.

Also, the browser console gives me a lot of these errors:

Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://open-vsx.org/vscode/gallery/extensionquery. (Reason: CORS header ‘Access-Control-Allow-Origin’ missing).

However, for other repositories I’m still able to install extensions (even though the same errors are being logged). :thinking:

This is very strange and I’ll continue investigating why it seems to fail specifically for your repository (which otherwise looks perfectly configured).

1 Like

Another thing I noticed that everything works as expected when I switch my editor preference to Theia in the Gitpod preferences.

Aha, thanks for this additional data point!

Meanwhile I forked your repository, and surprisingly when I open the (identical) fork in Gitpod (VS Code), I do got all extensions, but the Docker image is incorrect and the init task didn’t run. :thinking: Something fishy is going on. I suspect VS Code doesn’t like something about your configuration. I haven’t figured out what yet, but you may have uncovered a bug in VS Code / Gitpod’s distribution of it! :blush:

I’ll keep posting updates here as the investigation progresses. Meanwhile, if you’re happy to continue working with Theia for now, that’s cool. :+1:

1 Like

@jan Any updates? Here’s the errors I am getting.

We recommend switching to VS Code as we are going to stop support for Theia in August anyhow

Hi @IgnisDa!

Thank you for the ping :+1: Unfortunately, we weren’t able to fully understand the problem yet, so I’ve filed this issue:

I’ve also forwarded it to team members with deeper knowledge of VS Code. I’d suggest subscribing to that issue in order to be notified of updates.

I’ve filled an issue about a week ago but got no response

And there’s some more problems with VSCode, one of them being how unusable it is…

Hopefully this gets back on track.

1 Like

As a follow-up: please make sure that you tried with disabled browser extensions like adblocker or antivirus software. Sometimes they mess up with pages and break VS Code.