Error for one liner installs on GCP and Aws

I am trying to install the self hosted version with the one liners commands found in the docs here:

I get two different errors.
AWS: on .terraform/modules/kubernetes/versions.tf line 2, in terraform:
2: required_version = “>= 0.12.9, != 0.13.0”
GCP: googleapi: Error 400: Master version “1.15.12-gke.9” is unsupported., badRequest

Is there a way to fix this?

Hi,
both problems can be fixed in the Terraform scripts included in the repo.

  1. Remove your local .terraform directory and run terraform init again.
  2. Change the Kubernetes version in this file to “1.16.13-gke.401”.

Best regards
Wulf

Thanks,
so I need to rebuild the installer that is called in the one liner script in the doc page right?
Right now I have:

  • Forked the repo
  • Changed the line as suggested to "1.16.13-gke.401”

Next I think I need to build the image and deploy somewhere to change the

docker run --rm -it \
-v $PWD/gcloud:/root/.config/gcloud \
-v $PWD/gpinstall:/workspace \
eu.gcr.io/gitpod-io/self-hosted/installer:latest \
gcp

to point to the image. Correct?

Hey,
I answered the question in some more detail here. maybe it will help at least for your aws instance.

The installer is putting all configurations and Terraform scripts to your local drive. From this on you can run Terraform directly from your command line if you have Terraform already installed.