Debugger support

Dear all, it seems that debugger break points do not work in the IDE as of now.

Project:
https://d5599935-4039-4788-bb3e-056e2c3d9376.ws-us02.gitpod.io/#/workspace/HelloGitPod
(so pretty much hello gitpod)

Config:
{
// Use IntelliSense to learn about possible attributes.
// Hover to view descriptions of existing attributes.
“version”: “0.2.0”,
“configurations”: [
{
“type”: “gdb”,
“request”: “launch”,
“name”: “Launch Program”,
“target”: “./build/HelloGitPod”,
“cwd”: “${workspaceRoot}”,
“valuesFormatting”: “prettyPrinters”,
“debugger_args”: ["-ex=set disable-randomization off"]
}
]
}

cf screenshots

Setting “br main” solves the problem partially, as you have to enter “step” manually…
Could you update the doc and may be check if there are better ways to do it?

Hi Zeta!

Is there Gitpod Snapshot a public GitHub repo that we can use to reproduce this bug?
You can create a snapshot by clicking on your avatar menu in the top-right of the IDE and then on “create workspace snapshot”.

Unfortunately, I can’t access the link you posted, because the workspace is either not shared or not running anymore.