Connect to external S3 storage with https

Does anyone know what parameters to use when connecting to an external S3 storage backend with https?

I am trying to connect with a 0.10.0 setup that I know works with Scaleway Object Storage (S3). Changing this to connect to an S3 service with pironet-ndh.com is not working.

When I try and set up a connection with WinSCP, I specify the file protocol “Amazon-S3” and also port 443 - so that a HTTPS connection is made.

These are my settings:

  contentService:
    remoteStorage:
      kind: minio
      minio:
        endpoint: s3-xxx.pironet-ndh.com:433
        protocol: https
        accessKey: XXX
        secretKey: XXX
        region: us-east-1
        tmpdir: /gitpod

I have created the tmpdir myself and know this exists. I can see it from WinSCP.

When I try and create a new workspace I get the following error:

Oh, no! Something went wrong!
cannot initialize workspace: 
cannot use configured storage: 
Get "http://s3-xxx.pironet-ndh.com:433/gitpod-user-4086b6e3-ea29-4f3a-990f-48c19a0fb647/?location=": dial tcp 195.82.90.49:433: i/o timeout; last backup failed: workspace does not exist. Please contact support if you need the workspace data.

Looks like I may have solved it myself…

Looking through the code (I know nothing about Go :wink: ) I could see there is a secure bollean parameter. Setting this to true seems to have done the trick!

So something like this:

contentService:
    remoteStorage:
      kind: minio
      minio:
        endpoint: s3-xxx.pironet-ndh.com:433
        secure: true
        accessKey: XXX
        secretKey: XXX
        region: us-east-1
        tmpdir: /gitpod