Can't start basic workspace?

Hello,

I can’t start a simple workspace with a .gitpod.yml file of:

# The Docker image to run your workspace in. Defaults to gitpod/workspace-full
image: python:alpine3.13

This seems pretty simple so I assume it’s a k8s problem on the gitpod.io side.

Strangely, python:latest works but not that specific image – yet the image exists from what I can tell on docker hub.

Do you get any error messages?

Gitpod has some expectations for the image (see the scripts that are executed on the image here). Currently, the best way is to use gitpod/workspace-base or gitpod/workspace-full as your base image (and add additional software if needed there). Probably the python alpine image does not work with the gitpod-layer scritps.