Can't connect to an open port

I am trying to run this repo on Gitpod. I followed the instructions, installed, and ran the proxy, and the port opens up on 7080. But when I try to connect, I get “Port 7080 Not Found.”

Any tips? (I would appreciate it if you yourself tried to make a gitpod workspace with the repo, thank you :))

Could you elaborate how do you start it?
I tried:

npm i
npm run start

but it fails with:

gitpod /workspace/proxy $ npm start

> sys-proxy@1.0.4 start /workspace/proxy
> node ./demo/index.js

/workspace/proxy/node_modules/sys-nodehttp/index.js:672
                if(this.config.static)throw new TypeError('`static` has been changed. Check documentation or try: server.use(nodehttp.static(' + JSON.stringify(this.config.static) + '))');
                                      ^

TypeError: `static` has been changed. Check documentation or try: server.use(nodehttp.static("/workspace/proxy/demo/public"))
    at new server (/workspace/proxy/node_modules/sys-nodehttp/index.js:672:31)
    at Object.<anonymous> (/workspace/proxy/demo/index.js:7:11)
    at Module._compile (internal/modules/cjs/loader.js:1063:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:1092:10)
    at Module.load (internal/modules/cjs/loader.js:928:32)
    at Function.Module._load (internal/modules/cjs/loader.js:769:14)
    at Function.executeUserEntryPoint [as runMain] (internal/modules/run_main.js:72:12)
    at internal/main/run_main_module.js:17:47
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! sys-proxy@1.0.4 start: `node ./demo/index.js`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the sys-proxy@1.0.4 start script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/gitpod/.npm/_logs/2021-04-09T08_16_27_859Z-debug.log

I could not find docs on how to start from sources in README.