Cannot helm install gitpod with gitpod-gke-guide - <$comp.registry.secretName>: nil pointer evaluating interface {}.secretName

at commit a3714cd39798a27aa485ac73993ec499df0ab79c of gitpod-gke-guide, there seems to be something wrong with the chart.

Everything goes fine with make install until helm upgrade --install gitpod:

Installing Gitpod...
Release "gitpod" does not exist. Installing it now.
Error: template: gitpod/templates/image-builder-mk3-deployment.yaml:42:3: 
... executing "gitpod/templates/image-builder-mk3-deployment.yaml" at <include "gitpod.pod.dependsOn" $this>:
... error calling include: template: gitpod/templates/_helpers.tpl:71:25:
... executing "gitpod.pod.dependsOn" at <include (print $.Template.BasePath "/" $path) $>:
... error calling include: template: gitpod/templates/image-builder-mk3-configmap.yaml:33:24:
... executing "gitpod/templates/image-builder-mk3-configmap.yaml" at <$comp.registry.secretName>:
... nil pointer evaluating interface {}.secretName
make: *** [Makefile:20: install] Error 1

The .env contains

DOMAIN=gitpod-ttt.ddd.xxx
PROJECT_NAME=ppp
BILLING_ACCOUNT=aaa...a
REGION=europe-north1
GKE_VERSION=1.20.9-gke.700
ZONES=
CLUSTER_NAME=ccc
PREEMPTIBLE=true
LETSENCRYPT_EMAIL=eee@ddd
SETUP_MANAGED_DNS=true
MYSQL_INSTANCE_NAME=gitpod
CONTAINER_REGISTRY_BUCKET=
IMAGE_PULL_SECRET_FILE=sss.conf
IMAGE_REGISTRY_WHITELIST=

To even reach this, had to slightly tweak gitpod-gke-guide:

diff --git a/Makefile b/Makefile
index 85e2de6..7b5bae8 100644
--- a/Makefile
+++ b/Makefile
@@ -10,7 +10,7 @@ build: ## Build docker image containing the required tools for the installation
 
 DOCKER_RUN_CMD = docker run -it \
        --volume $$HOME/.config/gcloud:/root/.config/gcloud \
-       --volume $$HOME/.kube/config:/root/.kube/config \
+       --volume $$HOME/.kube:/root/.kube \
        --volume $$PWD:/gitpod \
        ${IMG} $(1)
 
diff --git a/setup.sh b/setup.sh
index 7bc4d98..c4b14a1 100755
--- a/setup.sh
+++ b/setup.sh
@@ -324,7 +323,6 @@ function install() {
             --disk-type="pd-ssd" --disk-size="50GB" \
             --image-type="UBUNTU_CONTAINERD" \
             --machine-type="e2-standard-2" \
-            --cluster-version="${GKE_VERSION}" \
             --region="${REGION}" \
             --service-account "$GKE_SA_EMAIL" \
             --num-nodes=1 \

(The install messes up your .kube/config ownership anyway, as docker is running as root.)

@teemu.anttila-arek please make sure you are using the latest version. The issue you mention was fix here

Thanks for the quick and accurate response.
The install works fine with gitpod-gke-guide commit 632bdd9ce39a97450c0dbb73ea8a717cf0023c33.