Cannot get self hosted gitpod working on ubuntu k3s cluster

Hi guys i am trying to self host gitpod on ubuntu server using this guid https://www.gitpod.io/docs/self-hosted/latest/installation/on-kubernetes i have all except svclb-proxy-mxdbs pod not running .

NAME READY STATUS
svclb-proxy-mxdbs 0/2 Pending
minio-f8c5dddbc-gvdhm 1/1 Running
content-service-8685487f7d-xvd4s 1/1 Running
ws-scheduler-6c96d46dd5-z6df9 2/2 Running
blobserve-7fd8f4d867-gkjjb 2/2 Running
ws-manager-bridge-665c44dc55-bbvzl 1/1 Running
registry-facade-pnldx 2/2 Running
agent-smith-8zb8j 2/2 Running
dashboard-76bb64ffcb-9j8n5 1/1 Running
registry-6f9d8847c5-lkhsf 1/1 Running
proxy-79c76cfcd5-qmd7q 1/1 Running
mysql-0 1/1 Running
messagebus-0 1/1 Running
ws-proxy-66f477db4c-52xf9 0/1 Running
svclb-ingress-nginx-controller-jphcl 0/2 Pending
ingress-nginx-controller-fd7bb8d66-p5bxw 1/1 Running
ws-manager-85fbd4ffd8-nfxtn 2/2 Running
image-builder-74cb69dfc8-nn8g9 3/3 Running
server-79df6b44b-8dqqn 2/2 Running
ws-daemon-5rmgs 2/2 Running

When i describe that pod i get this issue

Warning FailedScheduling 21h default-scheduler 0/1 nodes are available: 1 node(s) didn’t have free ports for the requested pod ports

Also this command “k3s kubectl describe svc proxy | grep -i ingress” command does not return anything.

Can someone please let me know what i am doing wrong.

Do you have the SSL certificates for your cluster created correctly and registered as a secret in your cluster?

There were some changes to the SSL setup between 0.0.9 and 0.0.10 :

I have generated certificates using cerbot using this script on this link https://www.gitpod.io/docs/self-hosted/latest/configuration/ingress

root@gitpod:~# ll secrets/https-certificates/
total 24
drwxr-xr-x 2 root root 4096 Sep 7 17:24 ./
drwxr-xr-x 3 root root 4096 Sep 6 14:37 …/
-rw-r–r-- 1 root root 424 Sep 7 17:25 dhparams.pem
-rw-r–r-- 1 root root 5668 Sep 6 18:14 tls.crt
-rw------- 1 root root 1704 Sep 6 18:14 tls.key

after this i have fired these commands

openssl dhparam -out secrets/https-certificates/dhparams.pem 2048
kubectl create secret generic https-certificates --from-file=secrets/https-certificates

helm upgrade --install -f values.custom.yaml gitpod gitpod.io/gitpod --version=0.10.0

I did manage to resolve this issue by disabling traefik

so went to file /etc/systemd/system/k3s.service

and added "–disable traefik "

ExecStart=/usr/local/bin/k3s \
server \
--disable traefik \

and then restart k3s
sudo systemctl daemon-reload
sudo systemctl restart k3s.service

Aah - yes.

I believe it is mentioned somewhere in the docs that traefik should be disabled as Gitpod is creating their own load balancing.

You may need to review your other k3s settings - depending on how your stack works now.

Thanks