Built-in VSIX extensions now use older version?

I’m seeing some issues with the Python extension opening notebooks as of this weekend. These issues were resolved in the latest versions of the extension (see https://github.com/eclipse-theia/theia/issues/3186). However, I now get the '‘No available file system provider for schema file’ error also reported here: https://github.com/eclipse-theia/theia/issues/8022. You can reproduce by trying to open the notebook in this Gitpod: https://gitpod.io/#https://github.com/intro-to-geoprocessing/week6-lab.

If I look in the built-in extensions list, the installed version of the Python extension seems to be 2019.11.50794 while the most recent version on Open VSX is 2020.9.112786. Other built-in extensions also seem to be older versions.

As far as I can tell, this is still an issue as of right now. Would anybody from the Gitpod team be able to look into this? As mentioned, the versions for any of the built-in extensions seem to be quite old as of right now. This seems to be a regression because newer versions were available a few weeks ago.

As these extensions are already pre-installed, I can’t solve the issue by manually installing my own updated version.

Hi @abesnabe! I’m seeing Python 2020.9.112786 as the built-in extension when opening the repository you linked. Have you tried creating a new workspace?

UPDATE: FYI I’ve also pushed https://github.com/open-vsx/publish-extensions/pull/212 to update the version to 2020.10.332292344.

Thanks @gtsiolis. Here’s the funny thing – even with a new workspace I’m still on the ‘old’ versions of the extensions. In fact, even when I open another new project/workspace, like Gitpod’s own repo, I see the same:

The screenshot shows all the built-in extensions to be an old version. Is this perhaps account related? I know it’s not isolated to my account as I had been using Gitpod in my class and students reported the same issue.

We are planning to release new version soon. It will have a new Theia with the new python extension. We also working on supporting other IDEs: https://github.com/gitpod-io/gitpod/issues/1780 It would allow to run Gitpod version of Code or trying nightly Gitpod Theia.

You can always override the built-in extension by installing it for your user or project: https://www.gitpod.io/docs/vscode-extensions/#installing-an-extension

1 Like

Thank you! I’ll wait for the new version to come out and give this another try.

Just to give you a data point, things worked fine until a few weeks ago and only recently all the extensions on gitpod.io seem to have regressed to an older version for me. So this is not isolated to the Python extension. Unfortunately, overriding the extension doesn’t seem to work either. Installation works fine:

vscode:
  extensions:
    - ms-python.python@2020.10.332292344:5ctthQ25Qni5/aAuOIUTYQ==

But afterwards activating it errors out. Snapshot in case you’re interested: https://gitpod.io/#snapshot/0758007c-655e-4c61-aa90-d13bbbd8bdad.

2 Likes