AWS CLI version 2 Issue

While Installing Gitpod In Amazon Ec2 Centos 7

Installing Gitpod

docker run --rm -it
-e AWS_ACCESS_KEY_ID
-e AWS_SECRET_ACCESS_KEY
-v “$PWD/awsinstall”:"/workspace"
eu.gcr.io/gitpod-core-dev/dev/dev-environment:wth-update-terraform-0.13.5.8 aws

This Error Pulling up …

Note: AWS CLI version 2, the latest major version of the AWS CLI, is now stable and recommended for general use. For more information, see the AWS CLI version 2 installation instructions at: https://docs.aws.amazon.com/cli/latest/userguide/install-cliv2.html

usage: aws [options] [ …] [parameters]
To see help text, you can run:

aws help

aws: error: the following arguments are required: command

Hi @rajeshjnair,
the docker installer contains the aws-cli provided by alpine linux, not the latest client released by Amazon. But it should work nonetheless. Have you set up both environment variables (AWS_ACCESS_KEY and AWS_SECRET_ACCESS_KEY) ?

Best regards
Wulf

hi @wulfthimm
This is my cmd history
1 sudo yum install -y yum-utils
2 sudo yum-config-manager --add-repo https:// download. docker .com/linux/centos/docker-ce.repo
3 sudo yum install docker-ce docker-ce-cli contained .io
4 sudo systemctl start docker
5 export AWS_ACCESS_KEY_ID=[My KEY]
6 export AWS_SECRET_ACCESS_KEY=[My SECRET]
7 export AWS_DEFAULT_REGION=us-east-1
8 sudo docker run --rm -it -e AWS_ACCESS_KEY_ID -e AWS_SECRET_ACCESS_KEY -v “$PWD/awsinstall”:"/workspace" eu .gcr.io/gitpod-core-dev/dev/dev- environment:wth-update-terraform-0.13.5.8 aws

But still that show

hi @wulfthimm

This AWS Ec2 Centos 7 Machine FYI