Are extension packs supported?

Hi folks.
First: Gitpod is great, I really enjoy it!

It seems to me that VScode extension packs are not supported yet, isn’t?

At least my extension pack does not reload the contained extensions.
Here is a snapshot of a WS: https://gitpod.io/#snapshot/a340b239-3d5e-48ec-abe5-95301339e48b while having loaded the Epsilon EAG extension pack.

Or, have I done something wrong in my extension pack? It behaves as expected under VScode itself…

Regards, Denis

Hi Denis,

we are happy to hear that! Thanks!

Just checked that the bundled extensions of grammarcraft.epsilon-eag-extension-pack are also in the registry :heavy_check_mark: There isn’t any error reported. From Theia, that appears to be supported.

We need to check if that’s an Gitpod or Theia issue…

cf. https://github.com/gitpod-io/gitpod/issues/2202